summaryrefslogtreecommitdiffstats
path: root/native
Commit message (Collapse)AuthorAgeFilesLines
...
* | | Revert "Split AndroidRuntime into AndroidRuntimeBase base-class and the rest."Andreas Huber2014-02-132-3/+1
| | | | | | | | | | | | | | | | | | This reverts commit 7825334929b098b36e1144872200e75ba6d24b13. Change-Id: I1702eb3ff9d7192d64039c8bf4bc3fc5d8e458c4
* | | Split AndroidRuntime into AndroidRuntimeBase base-class and the rest.Andreas Huber2014-02-122-1/+3
|/ / | | | | | | | | | | | | | | AndroidRuntimeBase (exported by libandroid_runtime_base.so) is all you need to link against to gain the ability to do AndroidRuntimeBase::getJNIEnv() thus minimizing build dependencies. Change-Id: Ia7f0c94c8c02b974c068e0db34774827f96aa95b
* | AArch64: Make AssetManager and related classes 64-bit compatibleAshok Bhat2014-01-311-2/+2
|/ | | | | | | | | | | | | | | | | | | | | | | | | | | | Following changes have been done: [x] Long is used to store native pointers as pointers can be 64-bit. [x] AssetManager openAsset native function returned -1 if file name was empty and java function considered any non-zero value as success. This has been fixed by native function throwing Illegal Argument Exception as well. [x] AssetManager incRefsLocked and decRefsLocked now accept long as input to support 64-bit native references. [x] AssetManager incRefsLocked method incorrecly used 'this.hashCode()' instead of the passed parameter id. This has been fixed. [x] Some minor changes have been done to conform with standard JNI practice (e.g. use of jint instead of int in JNI function prototypes) Change-Id: I095b9f900d49e51f43ad6afc47cbc23116a6a64a Signed-off-by: Ashok Bhat <ashok.bhat@arm.com> Signed-off-by: Craig Barber <craig.barber@arm.com> Signed-off-by: Kévin PETIT <kevin.petit@arm.com>
* Track Looper decoupling from ALooperBrian Carlstrom2013-12-182-8/+16
| | | | Change-Id: I54f4d36f105e60eaaa453ae60f591d634c681fd7
* Move input library code to frameworks/native.Jeff Brown2013-07-012-2/+3
| | | | | | | | | No longer compile libandroidfw as a static library on the device since it already exists as a shared library. Keeping the static library would force us to provide a static library version of libinput for the device as well which doesn't make sense. Change-Id: I3517881b87b47dcc209d80dbd0ac6b5cf29a766f
* am 09377ddb: Merge "Fix AMotionEvent_getHistorical* to take const ↵Andrew Hsieh2013-05-281-12/+12
|\ | | | | | | | | | | | | AInputEvent* motion_event" * commit '09377ddb93a964b9e0def6d84b8beb3a515f4a18': Fix AMotionEvent_getHistorical* to take const AInputEvent* motion_event
| * Fix AMotionEvent_getHistorical* to take const AInputEvent* motion_eventAndrew Hsieh2013-05-271-12/+12
| | | | | | | | | | | | See b.android.com/55873 Change-Id: Idff7b71480991e16f57e55748fafa57d5827b10b
| * Fix typoAndrew Hsieh2012-12-191-3/+3
| | | | | | | | Change-Id: I58f863c4eb1eb4196d001c280027ab59bee51ce4
* | Rewrite input handling for native applicationsMichael Wright2013-04-221-6/+21
| | | | | | | | | | Bug: 8473020 Change-Id: Ic4353d8924ab877bec21aff8c2dba9fe725bf906
* | Add liblogYing Wang2013-04-091-0/+1
| | | | | | | | | | Bug: 8580410 Change-Id: I746aa8258866508c3a725d0773faf4518096548f
* | Fix typoAndrew Hsieh2012-12-121-3/+3
|/ | | | | | Changed ANDROID_BITMAP_RESUT_SUCCESS -> ANDROID_BITMAP_RESULT_SUCCESS Change-Id: I3d5525d7dacbf8f007e3230e1ca87b69245a96b1
* am 768d9e1a: Merge "Correct executable bit for source files"Kenny Root2012-11-071-0/+0
|\ | | | | | | | | * commit '768d9e1a72ceee7d4a5f608776b87b62d6ce4a04': Correct executable bit for source files
| * Correct executable bit for source filesKenny Root2012-11-071-0/+0
| | | | | | | | | | | | | | | | | | Many media files and source code files were marked as executable in Git. Remove those. Also a shell script and python script were not marked as executable. Change-Id: Ieb51bafb46c895a21d2e83696f5a901ba752b2c5
* | Handle multi-user mountObb() requests.Jeff Sharkey2012-09-251-3/+12
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Since emulated external storage paths differ based on execution context, carefully fix up paths for various use-cases: 1. When sending paths to DefaultContainerService, always scope OBB paths as belonging to USER_OWNER. 2. When sending paths to vold, always build emulated storage paths visible to root. 3. Always use the original untouched path when talking with apps. Mount OBB containers using shared app GID, so that an app can read the mount point across users. Handle legacy paths like "/sdcard" by resolving the canonical path before sending to MountService. Move tests to servicestests, and add tests for new path generation logic. Bug: 7212801 Change-Id: I078c52879cd08d9c8a52cc8c83ac7ced1e8035e7
* | Merge "Add support for "-rtl" in resources" into jb-mr1-devFabrice Di Meglio2012-09-041-0/+10
|\ \
| * | Add support for "-rtl" in resourcesFabrice Di Meglio2012-08-231-0/+10
| |/ | | | | | | | | | | - fix bug #7035019 Need to have "-rtl" support for Resource Change-Id: Ic82145c2ac672729d8a6c695a5f343276a1a0a2c
* | Add plumbing for new surface flinger display API.Jeff Brown2012-08-271-1/+1
|/ | | | | | | | | | | | | | Cleaned up the implementation of Surface and SurfaceSession to use more consistent naming and structure. Added JNI for all of the new surface flinger display API calls. Enforced the requirement that all Surfaces created by the window manager be named. Updated the display manager service to use the new methods. Change-Id: I2a658f1bfd0437e1c6f9d22df8d4ffcce7284ca2
* libnativehelper is implicitly available.Elliott Hughes2012-05-032-4/+2
| | | | | | | (And is moving for the PDK.) Bug: 6369821 Change-Id: I9e082ef294cfb2d70384255eb06d97d8cb92b382
* Merge "ANativeWindow: support for application buffer dimensions"Jamie Gennis2012-04-111-6/+9
|\
| * ANativeWindow: support for application buffer dimensionsMichael I. Gold2012-04-101-6/+9
| | | | | | | | | | | | | | Make the NDK use the new native_window_set_buffers_user_dimensions to implement the ANativeWindow_setBuffersGeometry call. Change-Id: I2d5981cbd619ee2e090fe8f2ddc69217915c9d9e
* | Request key maps from input manager service.Jeff Brown2012-04-101-1/+0
|/ | | | | | | | | | | | | | | | | | Instead of each application loading the KeyCharacterMap from the file system, get them from the input manager service as part of the InputDevice object. Refactored InputManager to be a proper singleton instead of having a bunch of static methods. InputManager now maintains a cache of all InputDevice objects that it has loaded. Currently we never invalidate the cache which can cause InputDevice to return stale motion ranges if the device is reconfigured. This will be fixed in a future change. Added a fake InputDevice with ID -1 to represent the virtual keyboard. Change-Id: If7a695839ad0972317a5aab89e9d1e42ace28eb7
* move ndk headers to frameworks/nativeMathias Agopian2012-03-2316-3050/+1
| | | | Change-Id: I44e48b8993e8b574ae366b9e76629099154998a9
* add missing includeMathias Agopian2012-03-231-0/+2
| | | | Change-Id: I7eb05f6cb6de170aeb3b72d28490cdcf46982d13
* fix libgui header locationMathias Agopian2012-02-271-1/+1
| | | | Change-Id: Iec71706cdd4f29c6904993648ce873e83ef9cafe
* frameworks/base refactoringMathias Agopian2012-02-201-0/+1
| | | | | | create the new libandroidfw from parts of libui and libutils Change-Id: I1584995616fff5d527a2aba63921b682a6194d58
* frameworks/base refactoring.Mathias Agopian2012-02-173-5/+5
| | | | | | step 2: move libutils headers to their new home: androidfw Change-Id: I14624ba23db92a81f2cb929f104386e1fab293ef
* frameworks/base refactoring.Mathias Agopian2012-02-171-2/+2
| | | | | | First step. Move libui includes to their new home: androidfw. Change-Id: Ic042b52fdba72f30edc3cc6339bf30b4c1b99662
* Add xxhdpi; fix ActivityManager.getLauncherLargeIconSize() etc.Dianne Hackborn2012-01-251-0/+2
| | | | Change-Id: I519d6cdc527a402d93b98df17a64fc1da52ad598
* Rename (IF_)LOGE(_IF) to (IF_)ALOGE(_IF) DO NOT MERGESteve Block2012-01-082-4/+4
| | | | | | | See https://android-git.corp.google.com/g/#/c/157220 Bug: 5449033 Change-Id: Ic9c19d30693bd56755f55906127cd6bd7126096c
* Rename (IF_)LOGI(_IF) to (IF_)ALOGI(_IF) DO NOT MERGESteve Block2012-01-041-1/+1
| | | | | | | See https://android-git.corp.google.com/g/156801 Bug: 5449033 Change-Id: Ib08fe86d23db91ee153e9f91a99a35c42b9208ea
* Add a new ui mode for "appliance"Joe Onorato2011-12-151-0/+1
| | | | | | | | The idea is that this is a device which is more-or-less headless. It might have some limited interaction capabilities, but it's not something that you want to rely on having. Change-Id: Ib92f53a120bf83de781728011721a4859def7d9f
* am c339fe30: am be6ab576: Merge "Fix application launch shortcuts." into ics-mr1Jeff Brown2011-11-291-0/+4
|\ | | | | | | | | * commit 'c339fe302bc5083f0a110569eec06676be511088': Fix application launch shortcuts.
| * Fix application launch shortcuts.Jeff Brown2011-11-291-0/+4
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Improved quick launch bookmarks to support category-based shortcuts instead of hardcoding package and class names for all apps. Added a set of Intent categories for typical applications on the platform. Added support for some of the HID application launch usages to reduce reliance on quick launch for special purpose keys. Some keyboard vendors have hardcoded launch keys that synthesize "Search + X" type key combos. The goal is to encourage them to stop doing this by implementing more of HID. Bug: 5674723 Change-Id: I79f1147c65a208efc3f67228c9f0fa5cd050c593
* | Merge "Remove obsolete NativeWindow_fromSurfaceTexture"Glenn Kasten2011-11-152-16/+0
|\ \
| * | Remove obsolete NativeWindow_fromSurfaceTextureGlenn Kasten2011-10-212-16/+0
| |/ | | | | | | Change-Id: I9351103929da515cb411fb2e7906bb9f27c4da20
* | NDK: ANativeActivity: Fix documentation for 'clazz' member.David 'Digit' Turner2011-11-081-1/+8
|/ | | | | | | | | | | As discussed on the android-ndk forum, it turns out that the member named 'clazz' is really a global reference to the NativeActivity instance. As such, it's really a handle to a VM object, not a VM class. Ideally, we would rename it to 'activity', but this cannot be done without breaking NDK source compatibility. Change-Id: I82ca1549b35346a3eacf9e84c4c836387fc883a6
* fix the float Rect in OpenGLRenderer to handle NANsMathias Agopian2011-09-191-0/+3
| | | | | | | | | | | | | | | - we want functions like isEmpty() to return true if NANs are involved in the Rect - also clean-up the intersect familly of calls - minor cleanup in the int32_t Rect as well These played a role in http://b/5331198. Bug: 5331198 Change-Id: I5369725ab482e4b83da9f1bd4cee5256e5de75b2
* Input system bug fixes, particularly for stylus.Jeff Brown2011-08-191-0/+1
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Bug: 5049148 Finished stylus support, including support for indirect stylus and mouse tools. Added TILT axis. When stylus tilt X/Y is available, it is transformed into an orientation and tilt inclination which is a more convenient representation and a simpler extension to the exiting API. Touch devices now only report touch data using a single input source. Previously touch devices in pointer mode would report both absolute touch pad data and cooked pointer gestures. Now we just pick one. The touch device switches modes as needed when the focused application enables/disables pointer gestures. This change greatly simplifies the code and reduces the load on the input dispatcher. Fixed an incorrect assumption that the value of ABS_(MT_)DISTANCE would be zero whenever the stylus was in direct contact. It appears that the correct way to determine whether the stylus is in direct contact (rather than hovering) is by checking for a non-zero reported pressure. Added code to read the initial state of tool buttons and axis values when the input devices are initialized or reset. This fixes problems where the input mapper state might have the wrong initial state. Moved responsibility for cancelling pending inputs (keys down, touches, etc.) to the InputDispatcher by sending it a device reset notification. This frees the InputReader from having to synthesize events during reset, which was cumbersome and somewhat brittle to begin with. Consolidated more of the common accumulator logic from SingleTouchInputMapper and MultiTouchInputMapper into TouchInputMapper. Improved the PointerLocation output. Change-Id: I595d3647f7fd7cb1e3eff8b3c76b85043b5fe2f0
* Remove ParcelSurfaceTexture and update MediaPlayerTed Bonkenburg2011-08-111-9/+1
| | | | | | | | | This removes the ParcelSurfaceTexture class since that functionality has been folded into Surface.java. The change also updates the MediaPlayer to get rid of setParcelSurfaceTexture() and modifies setTexture() to use the new Surface functionality in order to simplify the code. Change-Id: Iafa75ea3188263928128325d8a726786971b4de4
* Merge "Add notifyPixelsChanged() call to NDK unlockPixels()."Romain Guy2011-07-281-0/+6
|\
| * Add notifyPixelsChanged() call to NDK unlockPixels().Alexandre Elias2011-07-121-0/+6
| | | | | | | | | | | | | | Without this call, the NDK bitmap methods don't work in hardware-accelerated mode ( http://b/5017848 ). Change-Id: Icae6975757c9c9e83c0e9fc132161aa3004f8f28
* | Handle stylus buttons and tool types.Jeff Brown2011-07-251-2/+1
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Added TOOL_TYPE_ERASER. Refactored the InputReader to share more code between the various input mappers that handle button states and to simplify the accumulator implementations by having each one only handle a single type of input. Removed the concept of direct/indirect tool types from the API. If we add it back, it should be done in a manner that is orthogonal to the tool type itself, perhaps as a flags field on the pointer. The device source may well provide sufficient information anyhow. Change-Id: I811c22d95e8304269b6ee4f6d11a6b04f3cfc1b2
* | Add set_scaling_mode() to ANativeWindow.Mathias Agopian2011-07-191-1/+9
| | | | | | | | | | | | | | This allows to specify the scaling mode independently from the buffer size. Change-Id: Iaa2baa660445531a97d3fac192e580f4929c5d3b
* | move lock/unlock implementaion outside of Surface into SurfaceTextureClientMathias Agopian2011-07-152-33/+9
|/ | | | | | | | | | This makes ANativeWindow_lock/ANativeWindow_unlockAndPost work with ANativeWindows implemented by Surface and SurfaceTextureClient. Also, Surface now inherits directly from SurfaceTextureClient. Bug: 5003724 Change-Id: I9f285877c7bae9a262e9a7af91c2bae78804b2ef
* Hover and stylus API cleanup.Jeff Brown2011-06-271-1/+0
| | | | | | | Added missing setOnHoverListener method. Removed BUTTON_STATE_ERASER. Change-Id: I5d820d0a8e47fe5fd2d88e9fd9fc3fc6ce0dea0d
* Add ParcelSurfaceTexture Java class to enable ISurfaceTexture sharing via ↵tedbo2011-06-091-1/+9
| | | | | | | | | | | Binder. This adds a new ParcelSurfaceTexture.java class that can be instantiated with a SurfaceTexture and used to send the corresponding ISurfaceTexture interface to another process via Binder. The ParcelSurfaceTexture java object can then be used to create an ANativeWindow based on the SurfaceTextureClient interface. Change-Id: Ie38ea948b866e52f36a6d0f6cde19b54a8546817
* resolved conflicts for merge of 54cb63e2 to masterDianne Hackborn2011-06-021-0/+1
|\ | | | | | | Change-Id: I5b741a1781e3f76c03fc1534ffce871117effd10
| * Add "tv" density for 720p screens.Dianne Hackborn2011-05-271-0/+1
| | | | | | | | Change-Id: I028969b007f2fceea66947d77a2ae31ef1d1a630
* | resolved conflicts for merge of bbca8133 to masterDianne Hackborn2011-05-241-0/+1
|\ \ | |/ | | | | Change-Id: I81493674dceab848e41d380a77a37e5a9be06db6
| * Add "television" mode.Dianne Hackborn2011-05-231-0/+1
| | | | | | | | Change-Id: Ida1fdb61b036a8b489dbeda196fb4bc82e651b2b