aboutsummaryrefslogtreecommitdiffstats
path: root/lib/CodeGen/AsmPrinter/DwarfException.h
Commit message (Expand)AuthorAgeFilesLines
* Update aosp/master LLVM for rebase to r235153Pirama Arumuga Nainar2015-05-181-2/+2
* Update aosp/master llvm for rebase to r233350Pirama Arumuga Nainar2015-04-091-22/+23
* Update aosp/master LLVM for rebase to r222494.Stephen Hines2014-12-021-35/+2
* Update LLVM for rebase to r212749.Stephen Hines2014-07-211-129/+5
* Update to LLVM 3.5a.Stephen Hines2014-04-241-29/+36
* Add a MCTargetStreamer interface.Rafael Espindola2013-10-081-0/+3
* Revert "Give internal classes hidden visibility."Benjamin Kramer2013-09-111-4/+4
* Give internal classes hidden visibility.Benjamin Kramer2013-09-111-4/+4
* Remove the MachineMove class.Rafael Espindola2013-05-131-1/+0
* Factor out type info emission into separate routine.Anton Korobeynikov2012-11-191-0/+3
* Reorder the comments of EmitExceptionTable.Logan Chien2012-09-051-20/+20
* Remove unused private member variables uncovered by the recent changes to cla...Benjamin Kramer2012-07-201-11/+0
* Stub out support for Win64-style exceptions. Note that this is merely usingCharles Davis2011-05-271-0/+32
* Produce a __debug_frame section on darwin ARM when appropriate.Rafael Espindola2011-05-101-20/+0
* Use .cfi_sections to put the unwind info in .debug_frame when possible. WithRafael Espindola2011-05-101-0/+3
* Remove DwarfTableException.Rafael Espindola2011-05-051-67/+0
* Implement a really simple DwarfSjLjException.Rafael Espindola2011-05-051-0/+19
* Change DwarfCFIException's member variables to track what it actuallyRafael Espindola2011-04-291-6/+7
* Some first rudimentary support for ARM EHABI: print exception table in "text ...Anton Korobeynikov2011-03-051-0/+32
* Add CFI directives-based frame information emission. Not hooked yet.Anton Korobeynikov2011-01-141-0/+31
* Split stuff as a preparation for CFI directives-based frame information emissionAnton Korobeynikov2011-01-141-52/+72
* Rename "HasCalls" in MachineFrameInfo to "AdjustsStack" to better describe whatBill Wendling2010-05-141-2/+2
* Use the "NamedGroupTimer" class to categorize DWARF emission better.Bill Wendling2010-04-071-4/+0
* privatize more stuff, eliminate vtables.Chris Lattner2010-04-051-1/+1
* reprivatize now that DwarfWriter is gone.Chris Lattner2010-04-051-2/+1
* prune #includes, MMI can never be nullChris Lattner2010-04-051-3/+8
* make DwarfException not inherit from DwarfPrinter.Chris Lattner2010-04-051-10/+8
* remove the raw_ostream from various dwarf printing things.Chris Lattner2010-04-041-3/+3
* change EH related stuff (other than EH_LABEL) to use MCSymbolChris Lattner2010-03-141-11/+4
* remove dead code.Chris Lattner2010-03-121-5/+0
* Preliminary patch to improve dwarf EH generation - Hooks to return Personalit...Anton Korobeynikov2010-02-151-3/+0
* Use an index instead of pointers into the vector. If the vector resizes, thenBill Wendling2010-02-101-1/+1
* Fix "the the" and similar typos.Dan Gohman2010-02-101-1/+1
* constify a bunch of dwarf stuff now that the registerinfo methodChris Lattner2010-01-261-1/+1
* mcstreamerize .no_dead_strip and .reference for static ctors/dtors.Chris Lattner2010-01-231-2/+2
* rename the dwarf class to DwarfPrinter. This matches the filenameChris Lattner2010-01-221-1/+1
* rename GetPrivateGlobalValueSymbolStub -> GetSymbolWithGlobalValueBase,Chris Lattner2010-01-161-4/+4
* Remove isPod() from DenseMapInfo, splitting it out to its ownChris Lattner2009-12-151-1/+0
* Remove VISIBILITY_HIDDEN from the classes in this directory. Fixes bug 5507.Nick Lewycky2009-11-171-1/+1
* Refactor the code that creates the "dot-label" difference. This may be used inBill Wendling2009-11-171-0/+6
* Refactor code that checks if it's a call to a "nounwind" function.Bill Wendling2009-11-121-0/+4
* --- Reverse-merging r82282 into '.':Bill Wendling2009-09-201-6/+0
* Factor out label difference creation.Bill Wendling2009-09-181-0/+6
* Add helpful comment.Bill Wendling2009-09-101-0/+1
* Believe it or not, this is a simplification. :-)Bill Wendling2009-09-091-0/+7
* - Rename EmitCommonInformationEntry to EmitCIE.Bill Wendling2009-08-251-8/+7
* Rename functions to something more descriptive. At the very least mention theBill Wendling2009-08-251-7/+8
* Rename TargetAsmInfo (and its subclasses) to MCAsmInfo.Chris Lattner2009-08-221-2/+2
* Move the sjlj exception handling conversions to a back-end pass where theyJim Grosbach2009-08-171-1/+0
* SjLj based exception handling unwinding support. This patch is nasty, brutishJim Grosbach2009-08-111-0/+1